Accueil Forums Support communautaire WooCommerce Probleme édition de page depuis la mise à jour WP 4.9 et woocommerce

Ce sujet a 10 réponses, 3 participants et a été mis à jour par  Fred – WooFrance, il y a 6 mois.

11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #45844

    F.dis
    Participant

    Aujourd’hui mon wp déconne grave
    J’ai fait la mise à jour wp hier après avoir tout mis à jour côté plug et thème
    Et maintenant lorsque je suis sur une page et que je clic sur modifier la page il m’emmène vers le modif d’un de mes produits.

    Quelqu’un a le même problème ?

    #45846

    Fred – WooFrance
    Admin bbPress

    Bonjour

    Oui, même problème sur un de mes sites.

    En désactivant WooCommerce,  j’arrive a modifier les bonnes page. Mais la source du problème reste un mystère pour le moment.

    Quel thème utilisez vous ?

    Expert WordPress & WooCommerce - Fondateur du site WooFrance.
    Voir ma fiche Expert et me contacter >> ici <<

    #45847

    Fred – WooFrance
    Admin bbPress

    J’ai le sentiment qu’au chargement de la page à editer WordPress “execute le shortcode” woocommerce et s’emmele les pinceau il charge ducoup le contenu editorial de l’ID du premier produit WooCommerce de la page au le de charger le contenu editorial de la page WordPress a editer

    Expert WordPress & WooCommerce - Fondateur du site WooFrance.
    Voir ma fiche Expert et me contacter >> ici <<

    #45849

    Guy
    Modérateur

    Salut,

    Problème qui semble lié au thème Divi

    This issue happens only with the Divi theme running on WC 3.2.4. This patch fixes the issue: https://github.com/woocommerce/woocommerce/pull/17777

    You can either apply the patch yourself if you are comfortable doing that, roll WooCommerce back to 3.2.3 (It doesn’t happen in 3.2.3), or wait until WC 3.2.5 is released (which will be as soon as possible but will likely be farther than 1 week in the future). 

    Source: https://wordpress.org/support/topic/woocommerce-wordpress-admin-page-direct-problem/

     

    2 Utilisateurs ont dit : Merci à l'auteur pour ce message.
    #45861

    Fred – WooFrance
    Admin bbPress

    Je me posais justement la question…  Merci Guy

    Expert WordPress & WooCommerce - Fondateur du site WooFrance.
    Voir ma fiche Expert et me contacter >> ici <<

    #45864

    F.dis
    Participant

    Merci beaucoup comment faire pour revenir à la version précédente ?

    Je suis novice sur WP et je ne sais pas codé

    #45878

    Fred – WooFrance
    Admin bbPress

    Je pense qu’il va y avoir une mise a jour rapide de divi / etxra ou WooCommerce  incluant un patch pour corriger le pb.

    Sinon le mieux c’est d’applique le patch indiqué ici :

    https://github.com/woocommerce/woocommerce/pull/17777

     
    C’est apriori le fichier : Woocommerce/includes/shortcodes/class-wc-shortcode-products.php
    qu’il faut modifier
     

    Expert WordPress & WooCommerce - Fondateur du site WooFrance.
    Voir ma fiche Expert et me contacter >> ici <<

    #45887

    F.dis
    Participant

    Merci beaucoup je vais test

    #45890

    Fred – WooFrance
    Admin bbPress

    Je confirme la patch fonctionne !

     

    Expert WordPress & WooCommerce - Fondateur du site WooFrance.
    Voir ma fiche Expert et me contacter >> ici <<

    #45895

    F.dis
    Participant

    Tu as fait comment ?

    #45905

    Fred – WooFrance
    Admin bbPress

    J’ai modifier le fichier indiqué avec la solution proposé sur git

    Expert WordPress & WooCommerce - Fondateur du site WooFrance.
    Voir ma fiche Expert et me contacter >> ici <<

11 sujets de 1 à 11 (sur un total de 11)

Vous devez être connecté pour répondre à ce sujet.