Accueil Forums Les thèmes WooCommerce Thème Mystile conflit jquery

Mots-clés : , ,

Ce sujet a 7 réponses, 3 participants et a été mis à jour par  Guy, il y a 1 an et 4 mois.

8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #2893

    Jean
    Participant

    Bonjour, j’utilise le thème Mystile de Woocommerce et je rencontre un problème avec un plugin “Fancy product designer”. Lorsque je suis dans mon espace admin, je rencontre un problème “Uncaught TypeError: $ is not a function”

    J’ai remarqué que lorsque je mettais en commentaire la ligne

    require_once ( get_template_directory() . '/functions/admin-init.php' );

    , celà résolvait le problème du côté admin mais rendait inutilisable le côté front end.

    Je suis perdu je sais pas quoi faire, j’ai essayé plusieurs solutions rien n’y fait.

    Aussi j’ai remarqué que Jquery migrate était de version 3.0.0 côté front end alors qu’il était de version 1.4.1 côté admin, est ce une piste ?

    Merci d’avance

    Pièces Jointes:
    #2899

    Guy
    Modérateur

    Bonjour,

    D’abord est-ce que tout est jour ? WordPress, le thème et son framework, les plugins utilisés ?

    Si c’est OK fais l’essai avec un des thèmes par défaut.

    Si ce n’est toujours pas bon il faudra essayer en désactivant tous les plugins autres que Woocommerce et Fancy product pour vérifier un éventuel conflit.

    #2902

    Jean
    Participant

    Bonjour Guy et merci de ta réponse !

    J’ai justement créer un nouveau wordpress pour tester sans plugin à côté ! Je n’ai que Woocommerce et le plugin Fancy en question d’activer

    Je tiens à signaler que le problème ne survient qu’avec Mystile justement que j’aimerai gardé (une bonne base pour créer ses propres templates)

    La seule “solution” que j’ai trouvé c’est comme cité plus haut en fouillant dans le fichier “functions.php”. Mais généralement les fonctions dans ça influence sur le front end et pas l’admin..

    #2908

    Guy
    Modérateur

    Bonjour,

    J’utilise Mystile mais pas Fancy Product donc je ne peux pas tester.

    Je te conseille de contacter le support du thème Mystile. Mais précise bien qu’avec d’autres thèmes tu n’as pas de soucis sinon ils te renverront immédiatement vers le support de Fancy.

    #2910

    Jean
    Participant

    Bonjour,

    j’ai beau cherché partout un support pour ce thème mais je ne trouve rien.. Tu aurais un lien vers le support ?

    #2911

    Guy
    Modérateur
    #3556

    Fred – WooFrance
    Admin bbPress

    Salut

    Appartement ce thème n’est plus tenu a jour  :

    ” Note: This product has been retired. Documentation is no longer being updated.”

    - Plugin mise en conformité loi Hamon : Cliquez ici
    - Créez des Emailling Pro : Cliquez ici (300 Emails gratuits par jour)
    - Réglez vos problèmes d'Email WordPress / WooCommerce : Cliquez ici

    #3589

    Guy
    Modérateur

    Salut Appartement ce thème n’est plus tenu a jour : ” Note: This product has been retired. Documentation is no longer being updated.”

    J’avais eu une mise à jour le 10 avril, je ne m’attendais pas à ça. Pffff va falloir que je change de thème 🙁

8 sujets de 1 à 8 (sur un total de 8)

Vous devez être connecté pour répondre à ce sujet.