Notez cet article

Qu'est-ce que Yoast SEO
Yoast SEO arrête le support de son plugin pour les anciennes versions de WordPress

Si vous ne le connaissez pas encore SEO et un plugin WordPress woocommerce, qui aide à l'optimisation des pages Web de notre site pour le référencement. ( SEO = search engine optimization )

 

  • Balise méta
  • Sitemap
  • Analyse sémantique
  • ...etc

Avec plus de 5 million d'installations actives Yoast SEO est un plugin très répandu, sans aucun doute le plus répandu des plugins SEO pour WordPress & Woocommerce... Pour ainsi dire dès qu'on parle "référencement naturel" sur WordPress, on parle très souvent de Yoast SEO.

Yoast SEO arrête le support de son plugin pour les anciennes versions de WordPress

Bref, récemment Yoast SEO a annoncé qu'il arrêtait le support de son plugin pour les versions antérieures à WordPress 5.2.

Voir article ici : https://yoast.com/supporting-older-versions-of-wordpress/


La fin du support qu'est-ce que cela signifie ?

Celà signifie tout simplement que pour les futurs version du plugin Yoast SEO il n'y aura pas de tests de compatibilité effectués sur WordPress 5.1, WordPress 4.x et versions antérieures.

Yoast SEO arrête le support de son plugin pour les anciennes versions de WordPress

Autrement dit, à plus ou moins long terme, il est certain que le plugin ne seras plus compatible avec les version antérieure de WordPress.


Pour quelle raison Yoast arrête-t-il le support ?
Yoast SEO arrête le support de son plugin pour les anciennes versions de WordPress

Officiellement essentiellement pour des raisons techniques :

Yoast veut travailler avec des outils modernes, afin d'améliorer la performance de son outil, par exemple utiliser des fonction récente de PHP et on va trouver que dans des versions relativement récentes du logiciel.


Qu'est-ce que cela implique pour les utilisateurs de YOAST SEO

  1. si vous utilisez WordPress 5.2 ou version supérieur : aucun problème, Yoast garantie la compatibilité est mise à jour pour se version de WordPress.
  2. si vous utilisez une version antérieure de WordPress  < 5.1 :
    alors il vous faudra envisager plusieurs options :

 

    1. Premièrement mettre à jour votre WordPress : personnellement je vous le recommande, les mises à jour sont là pour apporter un plus à votre site : à ce soir en terme de fonctionnalités, performance, ou sécurité.
    2. Deuxième solution : rester sur une ancienne version de WordPress et rester sur une ancienne version de Yoast SEO. Bref ne pas bouger : sur du court terme ce n'est absolument pas problématique, une sur du long terme ça risque d'être pénalisant pour l'évolution du site.
    3. Troisième solution : ne plus utiliser Yoast SEO et le remplacer par un autre équivalent… cela risque d'être quand même un petit peu compliqué, il existe bien des plugin qui permettent d'optimiser les sites WordPress pour le référencement, je pense par exemple à l'excellence Smartcrawll de WPMUDEV que j'utilise très souvent personnellement, mets passer d'un plug-in un autre, n'est vraiment pas évident… cela risque de “ casser” votre référencement, et il vous faudra leur construire. par ailleurs, tot ou tard les plugin ne supporteront plus également les ancienne version de WordPress. donc quand même le mieux à faire c'est de faire une mise à jour de WordPress.

      Yoast SEO arrête le support de son plugin pour les anciennes versions de WordPress


conclusion :

Même s'il est dommage de voir que Yoast SEO abandonne le support des anciennes versions de WordPress, il y a une certaine logique à cela, l'idée c'est de progresser de préparer l'avenir afin d'être de plus en plus performant.

Personnellement je vous encourage régulièrement mettre à jour vos site WordPress / ou commerce, ainsi que vos Thèmes et plugins, c'est la meilleure façon, de conserver la compatibilité de Toulouse outils, c'est la meilleure façon d'assurer la sécurité Nono si tu, et c'est la meilleure façon d'optimiser la performance de celui-ci

et vous, que Pensez-vous de l'arrêt du support de YOAST SEO pour les ancienne version de WordPress ?

quel plugin dédié SEO utiliser où ?

qu'allez-vous faire ? mettre à jour votre site ou vous restez sur les anciennes versions ?